configuration/packages/little-a-map.nix

39 lines
1.1 KiB
Nix

{ fetchFromGitea
, gitUpdater
, lib
, rustPlatform
# Dependencies
, cmake
}:
rustPlatform.buildRustPackage rec {
pname = "little-a-map";
version = "0.12.3";
src = fetchFromGitea {
domain = "codeberg.org";
owner = "AndrewKvalheim";
repo = "little-a-map";
rev = "v${version}";
hash = "sha256-2BJDOluZarGnBPCt9wADH2DuDkP9nyt7RygnyphZRPw=";
};
cargoHash = "sha256-eU+0k1zwj/AUIfSLeFNWHrcvmDqsK1TCxqqGUnYSbGY=";
nativeBuildInputs = [ cmake ];
preCheck = ''
export TEST_OUTPUT_PATH="$TMPDIR"
'';
passthru.updateScript = gitUpdater { rev-prefix = "v"; };
meta = {
description = "Players can have little a mapif they've surveyed the area in-game. This tool renders a composite of player-created map items with the goal of minimizing external effects on survival gameplay.";
homepage = "https://codeberg.org/AndrewKvalheim/little-a-map";
license = lib.licenses.gpl3;
mainProgram = pname;
broken = lib.versionOlder rustPlatform.rust.rustc.version (lib.importTOML (src + "/Cargo.toml")).package.rust-version;
};
}