configuration/packages/mozjpeg-simple.nix
2023-11-28 09:46:03 -08:00

20 lines
365 B
Nix

{ resholve
# Dependencies
, bash
, coreutils
, exiftool
, file
, imagemagick
, libheif
, mozjpeg
}:
let
inherit (builtins) readFile;
in
resholve.writeScriptBin "mozjpeg" {
interpreter = "${bash}/bin/bash";
inputs = [ coreutils exiftool file imagemagick libheif mozjpeg ];
execer = [ "cannot:${exiftool}/bin/exiftool" ];
} (readFile ./resources/mozjpeg)