configuration/packages/zsh-abbr.nix
2022-08-17 14:56:00 -07:00

27 lines
688 B
Nix

{ fetchFromGitHub, lib, stdenv }:
stdenv.mkDerivation {
pname = "zsh-abbr";
version = "4.5.0"; # Note: 4.6.0 introduces noncommercial license
src = fetchFromGitHub {
owner = "olets";
repo = "zsh-abbr";
rev = "f10935fe3b08b990259bede5e481cc392848cae5";
hash = "sha256-X4a1HVuEYChd0pXd45l5UKDItlpRksVQpfwJbiMmSlI=";
};
dontBuild = true;
installPhase = ''
install -D -t $out/share/zsh/plugins/zsh-abbr \
zsh-abbr.zsh \
zsh-abbr.plugin.zsh
'';
meta = {
description = "The zsh manager for auto-expanding abbreviations, inspired by fish shell.";
homepage = "https://github.com/olets/zsh-abbr";
license = lib.licenses.mit;
};
}